It is currently Sun Dec 17, 2017 10:36 pm


Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: Lost Labyrinth Windows 7
PostPosted: Thu Nov 11, 2010 12:44 am 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
So there are a few issues in Windows 7 that prevent me from properly playing the game.

Except the mouse bug which I can live with there is a slowdown issue. Playing the game works fine the first few turns but it will go slower and slower until it goes like a crawl. The movement stops up after each move and pauses a bit before continuing to walk. Also under ambushes monsters really slowly appear in slow motion.

I noticed Lost Labyrinth constantly using 50% of my processor. I am using the latest version 4.3.4

Any ideas? I tried using a couple of older versions from the sourceforge archive but without any luck.

[Edit]: Oh I also tried tweaking around with the settings and using compatibility mode XP SP3 without any luck there either.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Fri Nov 12, 2010 3:32 pm 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
That sounds like what somebody wrote me for linux.
Strange I cannot reproduce it here.
The old versions will all use 100% processor time. (If you have more than one core only one will be completely used)

Does not matter in most cases, when we play on desktop machines.

But that the game gets slower and slower is really strange.
I will try to find that, but as its not happening on our machines this could be difficult :(


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Fri Nov 12, 2010 8:39 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
Yeah I'm using Dual Core so its consuming one of my cores.

It could be that I'm on a laptop, but before I installed win7 I had windows XP and a very old version of lost labyrinth (over 1 year ago) which ran just fine.

I will try to run the game on a different laptop with win7 and tell you how it goes.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sat Nov 13, 2010 4:39 am 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
I finished the conversion of the code to a unified screen and keyboard handling today.
So hopefully this will disappear with next version.
Took me 14 days of work to achieve that as the laby code was individual for every screen. And we have loads of them.

Code is getting better and better though :D

Try around and keep reporting as I do not have Windows 7 to test for myself.
Still using XP sometimes. Mostly I am on LinuxMint - KDE :lol:


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sat Nov 13, 2010 3:20 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
Good work. I would compile the latest revision myself but it seems PureBasic isn't free :( A pity, it might limit the amount of people who can actually do anything with your source.

I've tried Lost Labyrinth on other laptops with Dual Core and Windows 7 and they have the same issues.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sat Nov 13, 2010 5:24 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
Well, idle mode still just isn't actually in released version.
So 100% cpu usage all the time on all systems still.
But does not get slower and slower on others..
And yes, Pure Basic is not free, but people can compile free under Linux with the elice converter program.
You might try installing linux too. I'm sure laby will work better there ..
You can install linux in a virtual machine even if you are dead-set against dual boot machine setup.
Do you use win 7 32 bit or 64 bit version?
(probably does not make a difference though anyway)


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sat Nov 13, 2010 7:44 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
I had dualboot ubuntu/xp before I installed only win7. I found out I rarely used linux for anything so I sticked only with Windows ;)

I use 64-bit for the record. The other computers I tested with also used 64 bit. But I used 64-bit XP as well and as you mentioned it shouldn't matter if I use 64 or 32 bit systems.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sat Nov 13, 2010 9:28 pm 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
Compiling the svn version makes no sense right now as we changed a lot for the next version. you would not be happy with it. Too many things are not working correctly at this stage.

Windows is commercial so is the compiler :lol:

If its not working with your Win 7 but you want to play right now I guess you should try installing Ubuntu again as it costs nothing.

For us its a hard task to make the game work on the trillion windows versions out there. And none of us is using windows anymore.


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sun Nov 14, 2010 1:46 am 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
True, but number of downloads and players for windows (167784) is over ten times larger than Linux (13911).

It could of course be that Linux download the game using synaptics? But for some of us installing a new OS to play this pretty awesome game isn't a option :P But I do understand your problem for portability, especially since the developers don't use windows themselves. I have the same problem on my game project but in vice versa (all the devs are windows users!)

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sun Nov 14, 2010 3:43 am 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
Strange thing is that it runs on a lot of Windows 7 machines without problems.
Tried it on 2 machines of friends of mine.
And seems to run on close to all XP machines.
Lets see if the next version is running fine as we changed a lot. But as the changes are huge this time we need some more days until we are ready to release it.

Even if you use Windows as your main OS its not that easy to test it on all the versions out there. Differences are huge. And even if it runs on one XP does not necessarily mean it runs on all others :(

Its not possible to install laby with synaptics as its not accepted into the repos. We haven't had success in convincing the artists to use an open source licence for their artwork.
Kindof strange that programmers like to do that but artists don't.


Top
 OfflineProfile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3, 4  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
GuildWarsAlliance Style by Daniel St. Jules of Gamexe.net
Guild Wars™ is a trademark of NCsoft Corporation. All rights reserved.