It is currently Mon Dec 18, 2017 9:23 pm


Post new topic Reply to topic  [ 33 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sun Nov 14, 2010 12:24 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
Maybe the problem lies in that I'm using laptops?

Ah, you would need custom artists in your community. Is it all the game art that isn't GPL or is it only the background art?

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Sun Nov 14, 2010 11:16 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
Only the background art. The icons and tiles are all GPL.
The sounds are all creative commons, except 2 left-over legacy ones.


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Mon Nov 15, 2010 3:18 am 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
I've found http://opengameart.org to be pretty awesome there. It offers sprites, backgrounds, sounds, music, etc. all with the GPL lisence!

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Mon Nov 15, 2010 10:29 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
Okay, I've downloaded the source for 4.40 and compiled it natively with PureBasic in x64 under Windows.

That didn't help, I'm still having the same problem.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Wed Nov 17, 2010 4:34 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
well, at least you can run the game in debugger mode and see if there is something going wrong that is detectable with it.
If you want to test latest development version you need to get it from the SVN repository.
The sources you can get here are the ones used for the released version, so it's to be expected they behave the same.


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Wed Nov 17, 2010 7:18 pm 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
Next version will feature one picture I found on your suggested gamearts page. We use it for the desert level.
So there are only 6 pictures left we do not know where they are from.
Hopefully very soon laby will be completely legacy free :D


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Wed Nov 17, 2010 8:32 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
I tried compiling the latest SVN revision, but it had some problems starting the actual game after selecting the character and skills.

I'm not that familliar with Basic (I'm more of a C++ and Java developer), but I will look around if I see anything suspicious with the debugger. What six images are you missing?

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Wed Nov 17, 2010 11:03 pm 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
I'm not sure but I think I solved the slowdown problem.

In mainscreen.pbi under procedure laby_rahmen():
Code:
   ; Ueberbleibsel des Labyrinths uebermalen
   wohin = ScreenOutput()
   StartDrawing(wohin)
   FrontColor(RGB(0,0,0))
   Box(365,15,51,449)
   Box(15,365,335,51)
   StopDrawing()


It seems removing this code snippet fixed the slowdown problem. I haven't noticed any difference in the gameplay by removing the code.

I removed numerous other drawing stuff in the code as I was trying to find out what code was causing the slowdown, but that didn't seem like it was helping anything.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Thu Nov 18, 2010 7:33 pm 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
Good to know that drawing the box slowes laby down.
It should change the game a bit as the laby is drawn over its borders without it.
Will try again if this is still/really the case.

The pictures that are not free yet are:
Code:
FSI1, FSI6, FSI7, FSI11, FSI12, FSI13, FSI21


btw: Did you have to change a lot to make it work with actual purebasic version? We still use 4.20 to compile it.

We want to compile it for windows with mingw. I already get it compiled but run into other errors. If you like to help I explain to you how you get the actual C++ code for the game and what you have to change to make it work.


Top
 OfflineProfile  
 Post subject: Re: Lost Labyrinth Windows 7
PostPosted: Fri Nov 19, 2010 1:31 am 
User avatar

Joined: Thu Nov 11, 2010 12:38 am
Posts: 161
Location: Norway
I only needed to uncomment some joystick code (3 lines or so) to get it to compile with PureBasic 4.40 (x64).

Why first convert the code to c++ and then use mingw to compile it? Doesn't your purebasic compiler support other platforms? I think my compiler can target other platforms than windows.

_________________
Lost Labyrinth Developer
Check out my other game: Egoboo


Top
 OfflineProfile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 33 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
GuildWarsAlliance Style by Daniel St. Jules of Gamexe.net
Guild Wars™ is a trademark of NCsoft Corporation. All rights reserved.