It is currently Sat Dec 16, 2017 11:47 am


Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Mon Apr 07, 2014 9:23 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
These are the contents of LABY.LOG; the other .log files state the same:

Quote:
21:34:10 INFO: Logging system initialized (2014-04-07)...
21:34:10 INFO: Loading settings...
21:34:10 INFO: Initializing Hardware accelerated sprites
21:34:12 ERROR: Lost Labyrinth encountered a critical error!
Game version: 30.03.2014
Extended Version: No
Date: 2014-04-07 (21:34:12)
OS: Windows XP (64-bit)

Error message: Invalid memory access
Error location: procs_graphics.pbi (line 69)

The error is unrecoverable and Lost Labyrinth will now quit.


The logged error states the system is 64-bit, which is false.
Here are my system stats straight from DXDIAG:
Microsoft Windows XP Professional (5.1, Build 2600)
Compaq Deskpro EP/SB Series
Intel Pentium II, MMX, ~350 MHz
128 MB RAM
Page File ~500 MB (total available goes as much as 1 GB)
DirectX 9.0c (4.09.0000.0904)
(All DirectDraw/Direct3D tests passed).

Can this be resolved? I'm NOT running 64-bit Windows on a 128-meg machine, believe me; neither did I download the 64-bit complied .exe.

Thx guys in advance, really would appreciate your help,
vultures.

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 8:45 am 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 232
We will have a look at this codeline.
Can you remember where this happend?
What did you do to trigger this error?

Or does this come up everytime you start the game?

Sometimes the display of the architecture seems to be wrong.
We should check that as well.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 11:09 am 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
I appreciate any thought on this, Markus. Thx in advance.

edit: '2600' in Windows build information means Service Pack 3.

Yes, this happens every time when I try to play the game. However, I will try and download the .zip file one more time; perhaps a build that's a bit dated, what do you think? I may try running the game in 9x enviroment (that's not compatibilty mode but rather a secondary OS).
I was gonna try and translate the game files into Serbian, and this happened. When, and if I can run the game - I'm doing it altogether. :)

Cheers,
vultures

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 8:47 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
The reported code line is setting the bilinear filtering.
So, if the bilinear filtering make the game crash, try switching it off.

Please have a look at the settings for the game.
These should be at c:/Documents and Settings/$username/.lostlaby/settings.txt

The very last entry should be:
Code:
; graphics filtering: 0=no filtering  1=bilinear filtering
graphics_quality = 1


If the settings file has something other than 0 or 1 in there, then this
could explain the crash - though not how this value came to be.
My test system is also XP 32 and here the filter works.

If it works with off only, your automap screen will look pretty ugly unfortunately.

Pentuim II - holy cow - might be that the compiler created code that does not work on antique CPUs.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 11:15 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
Here is my $user/.lostlaby/settings.txt
Notice that upon the start/failure, the game just copied the values from the original file in the game folder.

Quote:
; Lost Labyrinth Settings File
; This in only a prototype!!!
; After saving in the game the actual settings file will be here:
; Users Homedirectory + '/.lostlaby/settings.txt'
;
ApplicationName = Lost Labyrinth
settings_version = 1.7
;
; language: english, german, spanish, norwegian
; hungarian, polish, french, chinese
language = english
;
; Options\delay_animation: One time animation (ms)
Options\delay_animation = 200
;
; Options\delay_animation2: Animation from Fx (ms)
Options\delay_animation2 = 20
;
; key_repeat: in milliseconds
key_repeat = 90
;
; joystick: 1=yes, 0=no
joystick = 0
;
; video: 2=widescreen, 1=fullscreen, 0=windowed
video = 0
;
; LabyPlaySound: 1=yes, 0=no
LabyPlaySound = 1
;
; music: 1=yes, 0=no
music = 1
;
; klicking: 1=yes, 0=no
klicking = 1
;
; auto-toggle: 1=yes, 0=no
auto-toggle = 0
;
; button5: 1=yes, 0=no
button5 = 0
;
; jars: 1=yes, 0=no
jars = 1
;
; stepcounter: show extra stepcounter below this number
stepcounter = 0
;
; stepred: show extra stepcounter in red below this number
stepred = 2
;
; new version check: 1=yes, 0=no
versioncheck = 0
;
; hide warning if monster checksum has failed: 1=yes, 0=no
hide_checksum_warning = 0
;
; upload error reports to improve bugfixing: 1=yes, 0=no
upload_error_report = 1
;
; display book: 1=yes, 0=no
display_book = 1
;
; save CPU cycles: 1=minimze CPU usage, 0=maximize performance
save_cpu_cycles = 0
;
; show tutorials: 1=yes, 0=no
show_tutorials = 1
;
; load modded maps: 1=yes, 0=no
load_modded_maps = 1
;
; screen blinks red when injured: 2=never 1=when heavily injured, 0=always (default)
flash_screen_on_injury = 0
;
; logger level: 5=verbose 4=debug 3=info 2=warning 1=errors, 0=disabled
logging_level = 3
;
; quicksave slots: q=selected .=not selected
quicksave_slots = ..........


I'll try and adjust the graphics quality setting; let you know too, soon enough. :) Thx a lot, Grunz!

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Wed Apr 09, 2014 3:54 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
Yes, simply add the missing lines to the file.
The game seems to have crashed before actually writing out a new settings file.
That one would have that line in it. We forgot to add it to the template file, but that usually did not cause any problems .. missing values would use their default instead.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 11:00 am 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
Depending on double-buffering restriction to ignore error(69) yielded no results. I've been experimenting with various OpenGL drivers also, only to come to the same end.
Somehow I think this is all due to that 64-bit OS error. Altough I've never encountered it before with a roguelike, or any game for that matter, it's very hard for me to believe D3D double-buffering wins the issue here; it was not before long I improved on the pace of the gameplay with another game, skipping the triple-buffer which is a common nausea with such old hardware as mine here. OpenGL instructions, especially on newer builds, prevent playing many games built on a recent notice, altough I doubt Laby makes use of things like soft textures and complex polygons found in objects across the map.
I've been trying to find a Laby build that's perhaps a bit dated (before these kinda issues kicked in supposedly) but I had no luck. Is there an archive for those recent PureBasic Laby builds? I hope I could try the game before I build a Vista/Win7 computer.

One more time - thx in advance!

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 7:18 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 270
You are correct in that we don't use any 3d stuff, only simple sprites.
Still Purebasic is using OpenGL for quite a while now. So even the 2d
sprites are made with that.
Maybe versions that are 2 or 3 years old..
My guess is that the libraries used by Purebasic are using some opcodes that don't work on CPUs of that age cmov or whatever.

So putting "graphics_quality = 0" into the settings file did not help?

Oh, and the 64 bit message is our fault, the error log routine does write 64 bit whatever - fixed that now for next relase.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 7:47 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
Confirmed - OpenGL is the issue here; altough 2D/on-screen OGL rendering functions well with some other games, I suspect that PureBasic libraries make some calls to the OpenGL.dll that are not supported with older drivers and video cards. That is, Laby works suprisingly well on newer hardware. :)

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
GuildWarsAlliance Style by Daniel St. Jules of Gamexe.net
Guild Wars™ is a trademark of NCsoft Corporation. All rights reserved.