[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
lostlabyrinth.com • View topic - ERROR: Lost Labyrinth encountered a critical error!
It is currently Fri Sep 21, 2018 7:24 pm


Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Mon Apr 07, 2014 9:23 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 8:45 am 
Site Admin
User avatar

Joined: Mon Oct 12, 2009 2:30 am
Posts: 233
We will have a look at this codeline.
Can you remember where this happend?
What did you do to trigger this error?

Or does this come up everytime you start the game?

Sometimes the display of the architecture seems to be wrong.
We should check that as well.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 11:09 am 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
I appreciate any thought on this, Markus. Thx in advance.

edit: '2600' in Windows build information means Service Pack 3.

Yes, this happens every time when I try to play the game. However, I will try and download the .zip file one more time; perhaps a build that's a bit dated, what do you think? I may try running the game in 9x enviroment (that's not compatibilty mode but rather a secondary OS).
I was gonna try and translate the game files into Serbian, and this happened. When, and if I can run the game - I'm doing it altogether. :)

Cheers,
vultures

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 8:47 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 277


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Tue Apr 08, 2014 11:15 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Wed Apr 09, 2014 3:54 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 277
Yes, simply add the missing lines to the file.
The game seems to have crashed before actually writing out a new settings file.
That one would have that line in it. We forgot to add it to the template file, but that usually did not cause any problems .. missing values would use their default instead.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 11:00 am 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
Depending on double-buffering restriction to ignore error(69) yielded no results. I've been experimenting with various OpenGL drivers also, only to come to the same end.
Somehow I think this is all due to that 64-bit OS error. Altough I've never encountered it before with a roguelike, or any game for that matter, it's very hard for me to believe D3D double-buffering wins the issue here; it was not before long I improved on the pace of the gameplay with another game, skipping the triple-buffer which is a common nausea with such old hardware as mine here. OpenGL instructions, especially on newer builds, prevent playing many games built on a recent notice, altough I doubt Laby makes use of things like soft textures and complex polygons found in objects across the map.
I've been trying to find a Laby build that's perhaps a bit dated (before these kinda issues kicked in supposedly) but I had no luck. Is there an archive for those recent PureBasic Laby builds? I hope I could try the game before I build a Vista/Win7 computer.

One more time - thx in advance!

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 7:18 pm 
User avatar

Joined: Tue Oct 13, 2009 12:06 am
Posts: 277
You are correct in that we don't use any 3d stuff, only simple sprites.
Still Purebasic is using OpenGL for quite a while now. So even the 2d
sprites are made with that.
Maybe versions that are 2 or 3 years old..
My guess is that the libraries used by Purebasic are using some opcodes that don't work on CPUs of that age cmov or whatever.

So putting "graphics_quality = 0" into the settings file did not help?

Oh, and the 64 bit message is our fault, the error log routine does write 64 bit whatever - fixed that now for next relase.


Top
 OfflineProfile  
 Post subject: Re: ERROR: Lost Labyrinth encountered a critical error!
PostPosted: Thu Apr 10, 2014 7:47 pm 
User avatar

Joined: Mon Apr 07, 2014 5:18 pm
Posts: 7
Confirmed - OpenGL is the issue here; altough 2D/on-screen OGL rendering functions well with some other games, I suspect that PureBasic libraries make some calls to the OpenGL.dll that are not supported with older drivers and video cards. That is, Laby works suprisingly well on newer hardware. :)

_________________
A proud fan of Elite:_Dangerous !


Top
 OfflineProfile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
GuildWarsAlliance Style by Daniel St. Jules of Gamexe.net
Guild Wars™ is a trademark of NCsoft Corporation. All rights reserved.